Elevated 503 Error Rate on Hosting

Incident Report for CloudCannon

Resolved

The incident has been resolved. We will produce a post mortem early next week.
Posted Feb 20, 2026 - 16:35 UTC

Update

Further issues have been identified and fixes have been released.
Posted Feb 20, 2026 - 16:00 UTC

Update

We are continuing to monitor for any further issues.
Posted Feb 20, 2026 - 14:10 UTC

Monitoring

Some 503 errors on hosted sites. We are monitoring the problem and working to release further improvements.
Posted Feb 20, 2026 - 14:08 UTC
This incident affected: Host (Hosting (sites.cloudcannon.com)).