Bitbucket authentication outage
Incident Report for CloudCannon
Resolved
We have reached out to the impacted users and organizations. Thank you for your patience, please reach out to support if you have any concerns.
Posted Aug 08, 2023 - 06:30 UTC
Monitoring
A fix has been implemented and we are monitoring the results.

Organizations that sync with Bitbucket as a GIT provider will require to re-authenticate. This can be done on Organization > Settings > Files > Bitbucket. https://app.cloudcannon.com/#organisation/bitbucket

We will also be contacting affected Organizations directly.
Posted Aug 08, 2023 - 04:14 UTC
Update
We are continuing to work on a release to fix this issue.
Posted Aug 08, 2023 - 02:43 UTC
Update
We are continuing to work on a fix for this issue.
Posted Aug 07, 2023 - 23:16 UTC
Identified
We have identified an issue with Bitbucket Oauth connections. We are working to release a fix by end of day that will allow users to reauthenticate their accounts with Bitbucket. Saves will continue to push to the local CloudCannon Git which can be pushed back to Bitbucket after the reconnection. Thank you for your patience, contact support if you have any questions or concerns.
Posted Aug 07, 2023 - 23:16 UTC
This incident affected: API/App (App (app.cloudcannon.com)) and Sync (Atlassian Bitbucket Git via HTTPS, Atlassian Bitbucket Webhooks).