Screenshots are failing to load assets

Incident Report for CloudCannon

Resolved

We have released a fix and screenshots have returned to normal. Site with broken screenshots will still be broken until a change occurs updating the effected pages. Changing a shared dependency across the sites will re-trigger screenshots for impacted sites (e.g. a layout or shared css file). Sites impacted are limited to sites which rely on case insensitivity of URLs in CloudCannon hosting.
Posted Mar 26, 2025 - 09:05 UTC

Investigating

We are investigating an issue where screenshots are not loading all assets on a website. This results in broken looking screenshots on some sites.
Posted Mar 26, 2025 - 04:14 UTC
This incident affected: API/App (App (app.cloudcannon.com)).