Slow hosting requests

Incident Report for CloudCannon

Resolved

This incident has been resolved.
Posted Mar 04, 2026 - 09:40 UTC

Monitoring

Requests were reporting higher than normal response times. We have released a fix and numbers are returning to normal. We are continuing to monitor the results.
Posted Mar 04, 2026 - 09:10 UTC
This incident affected: Host (Hosting (sites.cloudcannon.com)).