Elevated 503 Error Rate on Hosting

Incident Report for CloudCannon

Resolved

This incident has been resolved.
Posted Feb 20, 2026 - 08:34 UTC

Update

Servers haven't reported a 503 error in the last 6 hours. The improvements appear to be working well. We will continue to monitor the results.
Posted Feb 20, 2026 - 05:13 UTC

Update

We have released more improvements for this issue today, and we are continuing to monitor the results.
Posted Feb 20, 2026 - 02:59 UTC

Monitoring

Some 503 errors on hosted sites. We are monitoring the problem and working to release further improvements.
Posted Feb 19, 2026 - 22:44 UTC
This incident affected: Host (Hosting (sites.cloudcannon.com)).